查看内容

Magento2新安装的莫名其妙后台变灰,无法正常使用,是文件验证在做怪 ...

2019-4-29 15:20| 发布者: lutish| 查看: 280| 评论: 0

magento2.3/2.2/2.1存在部分WINDOWS主机 全新安装后报错
提示:page/js/require_js.phtml' in module: '' block's name: 'require.js'
修改以下位置文件
vendor\magento\Framework\View\Element\Template\File\Validator.php
2.3.1 位置为lib\internal\Magento\Framework\View\Element\Template\File\

Validator.php

找到下面的这一些并修改

改以下位置文件

  public function isValid($filename)
{
$filename = str_replace('\\', '/', $filename);
if (!isset($this->_templatesValidationResults[$filename])) {
$this->_templatesValidationResults[$filename] =
($this->isPathInDirectories($filename, $this->_compiledDir)
|| $this->isPathInDirectories($filename, $this->moduleDirs)
|| $this->isPathInDirectories($filename, $this->_themesDir)
|| $this->_isAllowSymlinks)
&& $this->getRootDirectory()->isFile($this->getRootDirectory()->getRelativePath($filename));
}
return $this->_templatesValidationResults[$filename];
}

修改为

  public function isValid($filename)
{
return true;
}
返回顶部